Erratic behaviour of Poppy Humanoid

english
software
humanoid
motors
Tags: #<Tag:0x00007fae8b603e48> #<Tag:0x00007fae8b603d08> #<Tag:0x00007fae8b603ba0> #<Tag:0x00007fae8b603a60>

#1

While instantiating poppy humanoid:
from poppy.creatures import PoppyHumanoid
poppy = PoppyHumanoid()
All the motors suddenly starts moving unpredictably and gets locked resulting into overload error and overheating error.
No changes were made in poopy-humanoid.json (default configuration), only ports for upper and lower parts were added like ‘COM3’ and 'COM4’
All the motors are in working condition.
Where am i going wrong?
Are motors wrongly configured? ( I tried resetting motors )


#2

Try to acces the motors with low level :

import pypot.dynamixel
print(pypot.dynamixel.get_available_ports())
dxl_io = pypot.dynamixel.DxlIO(pypot.dynamixel.get_available_ports())
motors = (dxl_io.scan(range(60)))
print(motors)
print(len(motors))
dxl_io.set_goal_position({12: 60})

Here is a notebook example, if you want to download the code : https://github.com/Roboticia/notebook_tuto/blob/master/Configurer%20les%20moteurs%20XL-320.ipynb
Tell if it works ?


#3

Hello,

I suspect that the motors are not correctly assembled. Have you checked the dots while building the robot like described here (warning 2 and 3) ? That puts the zero position of the motor.


#4

Thanks, It worked partially. Now I am able to initialise poppy=PoppyHumanoid(), but when i try to make the motors to zero position, it does not go to zero position, it moves somewhere else.
Can u help me with this?