Playback of recorded moves not smooth

software
Tags: #<Tag:0x00007f5ce786d530>

#21

Ok, that is the reason.
You can update your motors to an older firmware on windows using an old version of dynamixel wizard (without automatic update)
I am sorry, I do not remember the dynamixel wizard version to use I did the same error but I changed computer since.


#22

Youpi ! I did remember I documented it :slight_smile:
Here is the process :


#23

Thanks Thot I achieved return to MX-28 firmware :slight_smile: I can move every motor now with the dynamixel library. Moreover, I stil can not use the scripts of the project. When I set aTorso object a communication serial problem occurs when I try to run a rutine. I tried with autodetect robot but it gets a key error related that a model is not in the Models dictionary. Actually, I’m checking that error, and when a use scan() (from dxlio dynamixel library) I get a list with the motors but with an additional id, 253. There’s not any motor with this id.

Do you think this “ghost” motor is involved with the issue of setting a Torso object correctly?

Anyway, can move the every motor with dynamixel library is a great advance for me, thanks again Thot your advices have been very helpful.

Greetings


#24

On my side, I never use the torse or humanoid library, I always use pypot.Robot generic object with a json object since the configuration changes a lot in my case. It is more flexible.
r = pypot.Robot.from_json("robot.json")