Problems to id the dynamixels


#23

Oki, I think we got it ! I had this issue. When a motor is with an arrow (it is a check) it means it works with V2 protocol while the others are in protocol V1. They cannot be on the same line.
When you did the recovery, it was not a real recovery.

You have to downgrade the checked servo motors.
Follow this link :

I wish it ll work :slight_smile:


#24

Dear @Thot,

I tried to perform a recovery firmware. However, the dynamixel wizard does not detect the motor when I use the recovery firmware option. Only, the motor is recognized when I do a search, as shown in this video.

On the other hand, all motors (except motor 52) are detected individually, they have the same firmware version and all of them are detected using the option DXL 1.0.

I really don’t know what other test I can do.


#25

Pypot and usb2ax only works with firmware version 36 on MX. Do you have version 36 or 39 ?
You have to dowload 1.1.3 version of dynamixel wizard to make a recovery to version 36. With the current version of wizard, it is not possible.


#26

@Thot, thanks again for your help.

The Mx28 dynamixel have the firmware 39 ( they came like this when they were bought). They were working with ROS with dynamixel package and Python with PyPot as well using USB2AX.
The humanoid was working with all motors. However, from one moment to another, the servos stopped being recognized.

At this moment, I am using RoboPlus 1.1.3.0. This tool has Dynamixel Wizard 1.0.19.0.
I am doing a firmware recovery in order to get the firmware 36.
When I search the motors individually using USB2AX, dynamixel wizard recognizes the motors.
However, some motors are not found when USB2Dynamixel is used. (Some motors are found).
The recovery firmware only is working in that motors that are found using USB2Dynamixel. This is, using USB2AX the recovery firmware fails in the motor detection. Only USB2Dynamixel works. But, as mentioned, USB2Dynamixel does not detect all motors individually.
In this video I show this problem


#27

Try to connect the motor which is not detected by USB2Dynamixel with USB2Dynamixel and tick Dynamixel V2.0 before detection.
Now the new motors run with firmware 39… good to know !
We have to make tests so that now it is compatible with firmware 39.
I have no access to my Poppy until 5th december.


#28

Hi @Thot,
I tried your suggestion but does not work. :pensive: