Web app. & Ergo jr

web
français
ergo-jr
english
software
Tags: #<Tag:0x00007f5e095acbe8> #<Tag:0x00007f5e095b36c8> #<Tag:0x00007f5e095b2548> #<Tag:0x00007f5e095b1300> #<Tag:0x00007f5e095b0220>

#1

(english version below)

Bonjour à tous.

Je travaille sur un d’atelier éducatif qui a pour but le développement d’une application web permettant de piloter un Ergo Jr.

J’ai développé une première application (en Python) pour tester la faisabilité du projet. Elle permet de commander individuellement chacun des six moteurs de l’Ergo Jr. Elle servira de base pour développer les autres applications.

Comme je ne possède pas d’Ergo Jr, je l’ai testée avec un simulateur, et elle fonctionne correctement. J’ai eu l’occasion de la tester avec un Ergo Jr réel, mais là, l’application s’interrompt au bout d’un délai plus ou moins long. En tuant les processus python qui tournaient par ailleurs, l’application fonctionne correctement. Il y a apparemment conflit entre mon application, et les applications python qui sont lancées d’office.

Si vous voulez l’essayer, il suffit de lancer les commandes suivantes dans un terminal sur le Raspberry Pi (comme indiqué, vous devrez probablement au préalable tuer les autres processus python) :

git clone http://github.com/epeios-q37/atlas-python
cd atlas-python
python ErgoJr

puis d’ouvrir le lien affiché dans un navigateur web.

Vous pouvez ouvrir ce lien depuis n’importe quel appareil (votre smartphone, par exemple) sans avoir à le reconfigurer pour qu’il soit connecté au même réseau local que l’Ergo Jr. Et pas besoin de configurer votre routeur/box pour ouvrir un port vers l’Ergo Jr. Il n’est pas nécessaire qu’il soit accessible depuis internet. Il suffit qu’il ai accès à internet.

Il y a juste cette nécessité de devoir tuer tous les processus python qui se lance au démarrage pour que l’application fonctionne correctement ; si quelqu’un a une idée pour éviter cela…


Hello, everyone.

I am working on an educational workshop that aims to develop a web application to pilot an Ergo Jr.

I developed a first application (in Python) to test the feasibility of the project. It allows to operate each of the Ergo Jr’s six engines individually and will serve as a basis for the development of other applications.

As I don’t own an Ergo Jr, I tested it with a simulator, and it works fine. I had the opportunity to test it with a real Ergo Jr, but then the application stops after a more or less long delay. By killing the other python processes that were running, the application works correctly. There seems to be a conflict between my application, and python applications that are automatically launched.

If you want to try it, just launch the following commands in a terminal on the Raspberry Pi (as stated, you probably have to kill other python processes before):

git clone http://github.com/epeios-q37/atlas-python
cd atlas-python
python ErgoJr

then open the displayed link in a web browser.

You can open this link from any device (your smartphone, for example) without having to reconfigure it to be connected to the same local network as the Ergo Jr. And no need to configure your router/box to open a port to the Ergo Jr. It is not necessary for it to be accessible from the internet. All it needs is access to internet.

There is just this need to have to kill all the python processes that are automatically launched at boot for the application to work properly; if someone has an idea to avoid this…